intoDNS: DNS kayıtları, DNS Raporu, e-posta sunucuları ve alan adı yapılandırmalarınızı saniyeler içinde detaylı analiz eden kapsamlı kontrol ve doğrulama aracıdır.
Analiz Özeti: ✓ 47 Başarılı
NS Kayıt Sonuçları
DurumTest AdıBilgi
✓Domain NS KayıtlarıDNS sunucularından domain için NS kayıtları:
ns1.turkiye.gov.tr. ( 94.55.117.7 ) TTL=34304
ns2.turkiye.gov.tr. ( 94.55.118.8 ) TTL=34304
✓TLD Kök DNS Sorgusuİyi. 2 ad sunucusu mevcut
✓NS Sunucu Doğrulamasıİyi. Parent zone'dan GLUE kayıtları tutarlı. GLUE gerektiren NS kayıtları varsa doğru çözümleniyor.
✓NS İsim Geçerliliğiİyi. 2 kayıt bulundu. Tüm NS kayıtlarınız geçerli hostname formatında ve IP adreslerine çözümlenebiliyor.

1. ns1.turkiye.gov.tr. → 94.55.117.7 (TTL: 34304s)
2. ns2.turkiye.gov.tr. → 94.55.118.8 (TTL: 34304s)
✓Çoklu NS Analizi (RFC2182)İyi. RFC2182 bölüm 5'e göre en az 2, en fazla 7 NS kaydınız olmalı. 2 NS kaydınız var, bu kabul edilebilir.
SOA Sonuçları
DurumTest AdıBilgi
✓NS'ler aynı SOA seri numarasına sahipTamam. Tüm isim sunucularınız aynı SOA seri numarasına sahip: 2026061601
✓Birincil Nameserver (MNAME)Tamam. turkiye.gov.tr. birincil isim sunucusu olarak listeleniyor.
✓Seri NumarasıSOA seri numarası: 2026061601.
Önerilen format YYYYMMDDnn'dir (örn: 2024010101).
✓Yenileme DeğeriSOA REFRESH değeriniz: 28800. Bu değer çok düşük olabilir. Normalde 3600 (1 saat) veya üzeri önerilir.
Secondary sunucular bu sürede bir primary sunucuyu kontrol eder.
✓Tekrar Deneme DeğeriSOA RETRY değeriniz: 7200. İyi görünüyor.
Primary sunucu erişilemezse 120 dakikada bir tekrar dener.
✓Sona Erme DeğeriSOA EXPIRE değeriniz: 2419200 (4 hafta). Bu değer çok düşük olabilir. Önerilen minimum: 1 hafta.
Primary sunucuya erişilemezse secondary sunucular bu süre sonra zone'u geçersiz sayar.
✓Minimum TTLSOA MINIMUM TTL değeriniz: 10800. Bu, negatif önbellekleme için makul bir değer gibi görünüyor.
Bulunamayan kayıtlar 180 dakika boyunca önbelleklenir.
•SOA KaydıSOA kaydı şudur:

Birincil isim sunucusu: turkiye.gov.tr.
Yönetici E-posta adresi: dnsadmin@turkiye.gov.tr.
Seri numarası: 2026061601
Yenileme: 28800
Yeniden deneme: 7200
Süre sonu: 2419200 (4 hafta)
Varsayılan TTL: 10800
•SOA Tutarlılık KontrolüSOA değerleri tutarlı ve mantıklı görünüyor.
MX Sonuçları
DurumTest AdıBilgi
✓MX Kayıtlarıİsim sunucularınız aynı MX kayıtlarını bildiriyor gibi görünüyor. Bu test, eksik bildirilen MX kayıtlarını ve aynı hostname ait farklı IP'leri kontrol eder.
✓Farklı İsim Sunucularında Farklı MX Kayıtlarıİsim sunucularınız aynı MX kayıtlarını bildiriyor gibi görünüyor. Bu test, eksik bildirilen MX kayıtlarını ve aynı hostname ait farklı IP'leri kontrol eder.
✓MX İsim Geçerliliğiİyi. MX kayıtlarınızda geçersiz bir hostname tespit edilmedi.
✓MX IP'leri Genelİyi. Tüm MX kayıtlarınız genel IP'leri kullanıyor.
✓MX CNAME Kontrolüİyi. MX kayıtlarınız için CNAME sorunu yok.
✓MX A Kaydı Doğrudan Eşleme TestiMX kayıtları doğrudan bir A kaydına işaret ediyor, dolaylı bir CNAME yönlendirmesi yok. Bu, e-posta teslimatında gecikme veya hataları önler ve DNS yapılandırmasının doğru olduğunu gösterir.
✓MX IP Değilİyi. Tüm MX kayıtlarınız ana bilgisayar adlarıdır.
✓MX Kayıt Sayısıİyi. 2 MX kaydınız var. Mail sunucusu arızası durumunda yedeklilik sağlanmış.
✓Eşleşmeyen MX Aİyi. MX kayıtlarınız için farklı IP'ler tespit edilmedi.
✓Yinelenen MX A Kayıtlarıİyi. MX kayıtlarınız için yinelenen IP'ler bulunamadı. Bu iyi bir şey.
✓Reverse MX A Kayıtları (PTR)Reverse (PTR) kayıtları:
94.55.120.164 → mailgw2.turkiye.gov.tr
94.55.120.163 → mailgw1.turkiye.gov.tr
Tüm IP'leriniz için reverse (PTR) kayıtları var, bu iyi bir şey.
•SPF KaydıSPF kayıtları bulundu:
turkiye.gov.tr: v=spf1 a:mailgw1.turkiye.gov.tr a:mailgw2.turkiye.gov.tr ip4:94.55.120.192/27 -all

SPF Analizi:
turkiye.gov.tr için SPF kaydı (strict mod -all), bu iyi bir güvenlik uygulamasıdır.
A Kayıtları
DurumTest AdıBilgi
✓A Kaydı 1turkiye.gov.tr. → 94.55.118.33 TTL=23607s
✓ Genel IP adresi
PTR: www.turkiye.gov.tr
•IPv4 ÖzetiToplam 1 IPv4 adresi bulundu. Web sitesi bu adresler üzerinden erişilebilir.
✓AAAA Kaydı 1 (IPv6)turkiye.gov.tr. → 2a00:1d58:0:1902:94:55:118:33 TTL=23667s
✓ IPv6 desteği mevcut
✓Web ErişilebilirlikWeb sitesi erişilebilir durumda. HTTP ve HTTPS protokolleri test edilebilir.
ℹ Ping testi yapabilir veya traceroute ile ağ yolunu inceleyebilirsiniz.
•Sunucu KonumuIP adreslerinin coğrafi konumu ve ISP bilgileri 3. parti servislerde sorgulanabilir.
IP Sorgulama: 94.55.118.33
•DNS YayılımıDNS kayıtlarının dünya genelinde yayılım durumu kontrol edilebilir.
Global DNS Yayılımını Kontrol Et
WWW Sonuçları
DurumTest AdıBilgi
✓WWW A Kaydıwww.turkiye.gov.tr, şu IP adres(ler)ine yönleniyor: 94.55.118.33. Bu bağlantı için iyi.
TTL: 33585 saniye
•WWW CNAMEwww.turkiye.gov.tr için CNAME kaydı bulunamadı.
✓IPv6 Desteği (AAAA)www.turkiye.gov.tr için IPv6 (AAAA) kaydı bulundu: 2a00:1d58:0:1902:94:55:118:33. Modern ağlar için iyi.
DNS Sorgu Sonuçları
DurumTest AdıBilgi
✓Recursive Sorgu Kontrolü
✅ İyi. DNS sunucularınız recursive sorguları desteklemiyor.
✅ Tüm DNS sunucularınız recursive sorgulara yanıt vermiyor, bu güvenlik açısından iyi.
🛡️ Güvenli sunucular
94.55.117.7, 94.55.118.8
✓GLUE Kayıt Tutarlılığıİyi. Parent zone'dan GLUE kayıtları tutarlı. GLUE gerektiren NS kayıtları varsa doğru çözümleniyor.
✓NS için GLUE Analiziİyi. NS kayıtlarınız için GLUE kayıtları mevcut.
ns1.turkiye.gov.tr [94.55.117.7], ns2.turkiye.gov.tr [94.55.118.8]
✓Uyumsuz NS Kayıtlarıİyi. Tüm NS sunucuları aynı NS kayıtlarına sahip.
Tüm yetkili DNS sunucularınız aynı NS kayıt listesini döndürüyor, bu tutarlılık için iyi.
✓DNS Sunucu Yanıt Kontrolüİyi. Tüm DNS sunucularınız yanıt veriyor.
Parent sunucular tarafından listelenen tüm DNS sunucularınız DNS sorgularına yanıt veriyor.
✓NS İsim Geçerliliğiİyi. Tüm NS kayıtlarınız geçerli ve çözümlenebilir.
Tüm NS kayıtlarınız geçerli hostname formatında ve IP adreslerine çözümlenebiliyor.
✓Çoklu NS Analizi (RFC2182)İyi. RFC2182 bölüm 5'e göre en az 2, en fazla 7 NS kaydınız olmalı. 2 NS kaydınız var, bu kabul edilebilir.
✓Lame Sunucu Kontrolüİyi. Tüm NS sunucularınız yetkili.
Parent sunucular tarafından listelenen tüm NS sunucularınız domain için yetkili yanıtlar veriyor, lame sunucu yok.
✓Eksik NS Parent Kontrolüİyi. Tüm parent NS kayıtları domainde de mevcut.
Parent sunucular tarafından bildirilen tüm NS kayıtları domain'in kendi NS kayıtlarında da bulunuyor.
✓Eksik NS Raporlama Kontrolüİyi. Tüm domain NS kayıtları parent'ta da mevcut.
Domain'in kendi NS kayıtları parent sunucular tarafından da bildiriliyor.
✓Domain CNAME Kontrolü (RFC1912/RFC2181)İyi. Domain CNAME kaydına sahip değil.
RFC1912 2.4 ve RFC2181 10.3'e göre domainler CNAME kaydına sahip olmamalı. Bu kurala uyuluyor.
✓NS CNAME Kontrolü (RFC1912/RFC2181)İyi. NS kayıtlarınız CNAME değil.
RFC1912 2.4 ve RFC2181 10.3'e göre NS kayıtları CNAME olmamalı. Bu kurala uyuluyor.
✓Farklı Subnet Analiziİyi. NS sunucularınız muhtemelen 2 farklı alt ağda.
NS sunucularının farklı alt ağlarda olması tek nokta arıza riskini azaltır.
✓Public IP Analiziİyi. NS IP adreslerinizin çoğu genel.
NS sunucularınızın IP adresleri internetten erişilebilir.
✓TCP Bağlantı Desteğiİyi. DNS sunucularınız TCP bağlantılarını destekliyor.
DNS sunucularınız TCP bağlantılarını kabul ediyor. Bu büyük DNS yanıtları için gereklidir.
•Farklı AS AnaliziAS numaraları belirlenemedi. AS analizi mevcut değil.